Error en Java: FRM-92095: Oracle Jinitiator too low 1


Trabajando en un proyecto antiguo en java con oracle developer forms, me topé con un error al ejecutar la página que usa varios plugins/applets de java. El error indicaba «FRM-92095: Oracle Jinitiator too low. Please install version 1.1.8.2 or higher».

Mensaje de Error

Esto sucede porque la aplicación trabaja con jdk 1.4 y es compatible con jdk 1.6 (que ambos usan Jinitiator), sin embargo tenía instalado el jdk 1.7 por otro proyecto y netbeans usa el 1.7 por defecto ó 1.8 en su versión más reciente.

Si es una pc de un usuario común, se puede desinstalar las versiones actuales del jdk mayor e igual a 1.7, sin embargo los necesito para otros proyectos y buscando una solución que no fuera desinstalar, conseguí esta opción:

Vamos a la configuración de java / panel de control de java.

Configure Java

Luego en el panel, vamos a la pestaña «Java» y el botón «Ver». Allí encontramos la configuración de Java Runtime Environment.

Configurando Parámetros

En la columna de «parámetros de tiempo de ejecución de Java para applets» establecemos un texto para que inicie a través del jdk 1.7, el texto es el siguiente:

Nota: Las comillas dobles escribelas manulamente, que al copiar y pegar, como esto es una página html, usa otro formato para las comillas y no funcionará.

Luego cierras y vuelves a abrir el navegador (internet explorer) y debe funcionar todo correctamente, el error desaparecerá. Igualmente va a aparecer el mensaje «Java se ha bloqueado», continúas en el botón «ejecutar esta vez», «Reintentar», «Acepto los riesgos y deseo ejecutar esta aplicación» y finalmente «ejecutar».

Comparte
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  

Dejar un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

code

Una idea sobre “Error en Java: FRM-92095: Oracle Jinitiator too low